$re = '/#(.+?)\n{2}/s';
$str = '# This is a comment,
this is still the same comment.
This, too. These don\'t matter:## foobar #
code...
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);