#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b[A-F0-9][A-F0-9]?\b"
Local $sString = "IP Table:" & @CRLF & _
"CIP_ID Type Status DevID Port IP Address/SiteName" & @CRLF & _
" AD GWAY OFFLINE 4 41794 192.168.088.053" & @CRLF & _
"" & @CRLF & _
"DM-MD8x8>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")