# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*?)\.(wordX\..*)\. (.*)\./$1 - $2 - $3/gm;t' <<< "TITLE.wordX. aaa.: AAAAAAA;AAAAA. BBBB: bbbb.
"