package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)\.(wordX\..*)\. (.*)\.`)
var str = `TITLE.wordX. aaa.: AAAAAAA;AAAAA. BBBB: bbbb.
`
var substitution = "$1 - $2 - $3"
fmt.Println(re.ReplaceAllString(str, substitution))
}