import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)\\.(wordX\\..*)\\. (.*)\\.";
final String string = "TITLE.wordX. aaa.: AAAAAAA;AAAAA. BBBB: bbbb.\n";
final String subst = "$1 - $2 - $3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}