use strict;
my $str = 'TITLE.wordX. aaa.: AAAAAAA;AAAAA. BBBB: bbbb.
';
my $regex = qr/^(.*?)\.(wordX\..*)\. (.*)\./mp;
my $subst = '$1 - $2 - $3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";