import Foundation
let pattern = #"((tin)[[:blank:]]+(nóng)[[:blank:]]+24h)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
GIỚI THIỆU CHƯƠNG TRÌNH TRUYỀN HÌNH NGÀY MAI – THỨ HAI 12/10/2015
---
PTV xuất hiện : Quí khán giả thân mến, ngày mai thứ hai 12/10/2015, những nội dung chính trong chương trình TH của Đài PT&TH Tp Cần Thơ như sau :
* BUỔI SÁNG & TRƯA :
- 5H03’ Ca nhạc…
- 5H15’ Đồng cảm và sẻ chia (pl)
- 5H25’ (QC,QB các chương trình của Đài …)
- 5H30’ Thời sự Tp Cần Thơ
- 6H00’ Chuyên đề Dân số - Gia đình & Trẻ em
- 6H10’ ( Trailer về sốt xuất huyết)
- 6H15’ Phim tài liệu : NÔNG THÔN ỨNG PHÓ VỚI BIẾN ĐỔI KHÍ HẬU – T5 :
KHOA HỌC CÔNG NGHỆ GIÚP NÔNG DÂN THÍCH ỨNG BIẾN ĐỔI KHÍ HẬU (pl)
- 6H45’ Cẩm nang sống khỏe (197 –pl - Đay thao nhat)
- 7H00’ Làm chủ tay lái (39/15- pl - Nhường đường cho xe ưu tiên sao cho đúng )
- 7H05’ (Quảng cáo, QB các chương trình của Đài)
- 7H10’ Phim truyện VN : TÌNH NGƯỜI XỨ HOA– Tập 14/36
- 7H55’ (Quảng cáo, QB các chương trình của Đài)
- 8H00’ Bản tin tiếng Anh (pl)
- 8H10’ Góc khuất (182- pl -Thay đổi để hòa hợp…)
- 8H40’ (Quảng cáo, QB các chương trình của Đài)
- 8H45’ Phim truyện TQ : QUÁN TRÀ VUI VẺ - P2 -Tập 19&20/50
- 10H35’ ( Qc, Qb các chương trình của Đài…)
- 10H40’ Alo bác sỹ (277- Viêm phần phụ )
- 10H50’ ( Qc, Qb các chương trình của Đài…)
- 11H00’ Chương trình 11.00
- 11H15’ (QC,QB các chương trình của Đài …)
- 11H20’ Phim truyện Ấn Độ : MỐI TÌNH KỲ LẠ - Tập 179&180/192
- 13H05’ (QC,QB …)
=>
*BUỔI CHIỀU VÀ TỐI :
-13H10’ Vào bếp cùng khán giả (pl của ngày 09/10/2015)
-13H20’ (QC,QB các chương trình của Đài …)
-13H25’ Phim truyện ĐL : VÒNG XOÁY KIM TIỀN – Tập 137&138/400
-15H15’ (QC,QB các chương trình của Đài …)
-15H20’ Phim truyện VN : BÃO– Tập 1/40
-16H15’ Gõ cửa trái tim (198 – Những MV siêu dễ thương…)
-16H45’ (QC,QB các chương trình của Đài …)
-16H50’ Phim truyện TQ : THỜI NIÊN THIẾU BAO THANH THIÊN– P3 :
THIÊN MANG TRUYỀN KỲ – Tập 45
-17H40’ (QC,QB các chương trình của Đài …)
-17H45’ Phim Sitcom : TIỆM BÁNH HOÀNG TỬ BÉ - Tập 166
-17H55’ (QC,QB các chương trình của Đài …)
-18H00’ Chuyên đề Khoa học - Công nghệ & Môi trường
-18H10’ Cần thơ phố
-18H20’ Điểm tin thị trường
-18H25’ (QC,QB các chương trình của Đài …)
-18H30’ Thời sự Tp Cần Thơ /Dự báo thời tiết
-19H00’ (QC,QB các chương trình của Đài …)
-19H05’ Chuyện Bà Tám (297 –Bức tử rừng thông )
-19H15’ (QC,QB các chương trình của Đài …)
-19H20’ Phim truyện Indonesia : MƯU KẾ TÌNH YÊU – Tập 17&18/90
-21H05’ (QC,QB các chương trình của Đài …)
-21H10’ Phim truyện VN : BÃO –Tập 34/40
-22H00’ Món ngon mỗi ngày : GÀ CUỘN CẢI BÓ XÔI ĐÚT LÒ (pl)
-22H05’ Phim truyện VN : BÃO –Tập 35/40
-23H00’ (QC,QB các chương trình của Đài …)
-23H05’ Bản tin Thời sư TpCT
-23H15’ Bản tin thế giới
-23H25’ Bản tin tiếng Anh
-23H35’ Phim tài liệu : NÔNG THÔN ỨNG PHÓ VỚI BIẾN ĐỔI KHÍ HẬU – T6 :
CỘNG ĐỒNG TRONG ỨNG PHÓ BIẾN ĐỔI KHÍ HẬU
-00H05’ Phim truyện HQ : CUỘC CHIẾN HOÀNG CUNG – Tập 29/35
PTV xh trở lại :
Chương trình truyền hình của Đài PT&TH Tp Cần Thơ đến đây là hết,
Hẹn găp lại quí khán giả vào chương trình truyền hình sáng thứ hai.
- 18H10’ Tin nóng 24h ( + QC, QB…)
- 18H30’ Thời sự Tp Cần Thơ /Dự báo thời tiết
- 19H00’ Điểm tin thị trường
- 19H03’ (QC,QB các chương trình của Đài …)
- 19H10’ Hộp thư truyền hình
- 19H20’ (QC,QB các chương trình của Đài …)
- 19H25’ Chuyện Bà Tám (313- Chưa vui tăng lương… )
- 19H35’ (QC,QB các chương trình của Đài …)
- 19H40’ Phim truyện Indonesia : MƯU KẾ TÌNH YÊU – Tập 48&49/90
- 21H30’ Món ngon mỗi ngày : LẨU GÀ ỚT HIỂM (pl)
- 21H35’ Phim truyện VN : BƯỚC QUA BÓNG TỐI –Tập 24/30
- 22H30’ Tin nóng 24h (pl) ( + QC, QB…)
- 22H50’ (QC,QB các chương trình của Đài …)
- 22H55’ Bản tin Thời sự TpCT
- 23H05’ Bản tin thế giới
- 23H15’ Bản tin tiếng Anh
- 23H25’ Phim tài liệu : GIẢI PHÁP MỀM CHỐNG SAT LỞ VÙNG BIỂN CÀ MAU
- 23H40’ Phim truyện HQ : BẢN LĨNH NÀNG DÂU – Tập 16/88
PTV xh trở lại :
Chương trình truyền hình của Đài PT&TH Tp Cần Thơ đến đây là hết,
Hẹn gặp lại quí khán giả vào chương trình truyền hình sáng thứ ba.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)