use strict;
my $str = 'Dear {#var#},
Please find your Booking Confirmation details
Transcation ID : %%|TranscationID^{"inputtype" : "text", "maxlength" : "45"}%%
Truck No : %%|TruckNo^{"inputtype" : "text", "maxlength" : "15"}%%
From : %%|FromLoc^{"inputtype" : "text", "maxlength" : "30"}%%
To : %%|ToLoc^{"inputtype" : "text", "maxlength" : "30"}%%
Rent(INR) : %%|Fright^{"inputtype" : "text", "maxlength" : "8"}%%
Advance(INR) : %%|AdvanceAmt^{"inputtype" : "text", "maxlength" : "8"}%%
Loading Address : %%|LoadingAddre^{"inputtype" : "text", "maxlength" : "100"}%%';
my $regex = qr/%%([\S\s]*?)%%/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}