re = /%%([\S\s]*?)%%/
str = 'Dear {#var#},
Please find your Booking Confirmation details
Transcation ID : %%|TranscationID^{"inputtype" : "text", "maxlength" : "45"}%%
Truck No : %%|TruckNo^{"inputtype" : "text", "maxlength" : "15"}%%
From : %%|FromLoc^{"inputtype" : "text", "maxlength" : "30"}%%
To : %%|ToLoc^{"inputtype" : "text", "maxlength" : "30"}%%
Rent(INR) : %%|Fright^{"inputtype" : "text", "maxlength" : "8"}%%
Advance(INR) : %%|AdvanceAmt^{"inputtype" : "text", "maxlength" : "8"}%%
Loading Address : %%|LoadingAddre^{"inputtype" : "text", "maxlength" : "100"}%%'
# Print the match result
str.match(re) do |match|
puts match.to_s
end