package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*`)
var str = `a
b
c
d
e`
var substitution = "test"
fmt.Println(re.ReplaceAllString(str, substitution))
}