import Foundation
let pattern = #"(?<!.)([\s]*)(go|GO)\s*([\r\n])?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
use SCRATCH
GO;
--go
set nocount ON ;go;
go
' go '
'go'
'go
go'
create table gonogo ( go int null, nogo int null)
GO
insert INTO mungbean VALUES (1); go
GO
;
select * from mungbean
go
go
go;
'
select go from go
go
select go from allgo
GO
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)