import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?:From|To|Subject|References):)[^:\\n]*:\\s*\\K[^\\n]*";
final String string = "A date\n"
+ "From: One line of text\n"
+ "To: One or more lines\n"
+ "Subject: One or more lines\n"
+ "References: One or more lines \n"
+ "Paragraph 1 Title:\n"
+ "A paragraph\n"
+ "Paragraph 2 Title: Another paragraph\n"
+ "…. Etc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}