use strict;
my $str = 'httpsa://localhost/pwa/deals
https://localhost/pwa/deals
https://localhost/pwa/deals
https://localhost/pwa/deals/api/sdsdsd
fb.com/animesh
sleeptight.com
multitasking.com
a2.com
asdasdasd.com
sdsdc
check abunes.com/
#.in
google@http://asd.com
animes@google.com
test@test.com
--2-
www.com
http://www.computer.com.au/
f4.animesh@google.com
https://animeshsingh.in
http://animeshsingh.in/
someone.ag
someone.br/ads
www.test-my-skills.gov.cz/0999asd-xzc88?0-_/sad%20123/@asdas
Http://www.@test.com
Https://www.@test.com
https://asa .aasd.com
test@asda.test.cas
someone.com
asdasd.com/asdasd/asdasd/asdasd/@asasd
ftp://siva:asdas@sadasd/asd
adc
2@https://www.go.com
www.google.com
https://www.somehow.com/@aasd
https://www.test.facebook.com/@sdas
Https://www.test.com/@masdasd
www.instagram.com/f4animesh
http://www.animeshsingh.in
www.ASD.com';
my $regex = qr/^((http|https):\/\/)?(www.)?(?!.*(http|https|www.))[a-zA-Z0-9_-]+(\.[a-zA-Z]+)+(\/)?.([\w\?[a-zA-Z-_%\/@?]+)*([^\/\w\?[a-zA-Z0-9_-]+=\w+(&[a-zA-Z0-9_]+=\w+)*)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}