# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((http|https):\/\/)?(www.)?(?!.*(http|https|www.))[a-zA-Z0-9_-]+(\.[a-zA-Z]+)+(\/)?.([\w\?[a-zA-Z-_%\/@?]+)*([^\/\w\?[a-zA-Z0-9_-]+=\w+(&[a-zA-Z0-9_]+=\w+)*)?$"
test_str = ("httpsa://localhost/pwa/deals\n"
"https://localhost/pwa/deals\n"
"https://localhost/pwa/deals\n"
"https://localhost/pwa/deals/api/sdsdsd\n"
"fb.com/animesh\n"
"sleeptight.com\n"
"multitasking.com\n"
"a2.com\n"
"asdasdasd.com\n"
"sdsdc\n"
"check abunes.com/\n"
"#.in\n"
"google@http://asd.com\n"
"animes@google.com\n"
"test@test.com\n"
"--2-\n"
"www.com\n"
"http://www.computer.com.au/\n"
"f4.animesh@google.com\n"
"https://animeshsingh.in\n"
"http://animeshsingh.in/\n"
"someone.ag\n"
"someone.br/ads\n"
"www.test-my-skills.gov.cz/0999asd-xzc88?0-_/sad%20123/@asdas\n"
"Http://www.@test.com\n"
"Https://www.@test.com\n"
"https://asa .aasd.com\n"
"test@asda.test.cas\n"
"someone.com\n"
"asdasd.com/asdasd/asdasd/asdasd/@asasd\n"
"ftp://siva:asdas@sadasd/asd\n"
"adc\n"
"2@https://www.go.com\n"
"www.google.com\n"
"https://www.somehow.com/@aasd\n"
"https://www.test.facebook.com/@sdas\n"
"Https://www.test.com/@masdasd\n"
"www.instagram.com/f4animesh\n"
"http://www.animeshsingh.in\n"
"www.ASD.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.