import Foundation
let pattern = #"^((http|https):\/\/)?(www.)?(?!.*(http|https|www.))[a-zA-Z0-9_-]+(\.[a-zA-Z]+)+(\/)?.([\w\?[a-zA-Z-_%\/@?]+)*([^\/\w\?[a-zA-Z0-9_-]+=\w+(&[a-zA-Z0-9_]+=\w+)*)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
httpsa://localhost/pwa/deals
https://localhost/pwa/deals
https://localhost/pwa/deals
https://localhost/pwa/deals/api/sdsdsd
fb.com/animesh
sleeptight.com
multitasking.com
a2.com
asdasdasd.com
sdsdc
check abunes.com/
#.in
google@http://asd.com
animes@google.com
test@test.com
--2-
www.com
http://www.computer.com.au/
f4.animesh@google.com
https://animeshsingh.in
http://animeshsingh.in/
someone.ag
someone.br/ads
www.test-my-skills.gov.cz/0999asd-xzc88?0-_/sad%20123/@asdas
Http://www.@test.com
Https://www.@test.com
https://asa .aasd.com
test@asda.test.cas
someone.com
asdasd.com/asdasd/asdasd/asdasd/@asasd
ftp://siva:asdas@sadasd/asd
adc
2@https://www.go.com
www.google.com
https://www.somehow.com/@aasd
https://www.test.facebook.com/@sdas
Https://www.test.com/@masdasd
www.instagram.com/f4animesh
http://www.animeshsingh.in
www.ASD.com
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)