#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?<!\.)(?:(?:9[5-9]|10[0-5])(?:\.\d)?|106(\.0)?)(?!\.)\b"
Local $sString = "94.9 95 95.1 95.11 100 100.0 100x 1.100.1 y101 +104.2 103.2 105.99 106 106.0 106.1 107"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")