use strict;
my $str = '94.9 95 95.1 95.11 100 100.0 100x 1.100.1 y101 +104.2 103.2 105.99 106 106.0 106.1 107';
my $regex = qr/\b(?<!\.)(?:(?:9[5-9]|10[0-5])(?:\.\d)?|106(\.0)?)(?!\.)\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}