using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".";
string input = @"
Apu's Apartment · Bachelor Arms Apartments · Bad Dream House · Bart's Tree House · Blue House · Bob's Victorian House · Boxingham Palace · Brown House · Burns Manor · Castle Recycle · Cool Brown House · Crap Silo · Crazy Cat House · D'Amico Summer Home · Elf Home · Fat Tony's Compound · Flanders House · Frink's Lab · Gingerbread House · Italian Villa · Kamp Krusty · Kane Manor · Krabappel Apartment · Lovejoy Residence · Mansion of Solid Gold · Muntz House · Old Simpson Farm · Orange House · Pink House · Powell Mansion · Powers House · Presidential Estate · Pumpkin House · Purple House · Quimby Compound · Retirement Castle · Rigellian Tribal Hut · Sanjay's House · School Bus · Scandal-Gate Hotel · Self-Reliant House · Simpson House · Skinner House · Sleep-Eazy Motel · Spinster City Apartments · Spooky House · Springfield Arms · Springfield Museum · Stacy's Dream House · Stu's Disco · Tetanus Terminal · Ultrahouse 2 · Van Houten House · Volcano Lair · White House · Wiggum House · Willie's Shack · Wolfcastle's Mansion · Zenith City Apartments · Zenith City Lofts · Zenith City Store Front Abandoned Store · Alley McBalls · Android's Dungeon · Barney's Bowlarama · Basketball Stadium · Big T Theatre · Blocko Store · Bloodbath & Beyond · Caesar's Pow-Wow Casino · Claus Co · Costington's · Drive-In Theater · Fireworks, Candy & Puppies · Gas and Grub · Gold Navy · Guitar Central · Gypsy Fortune Teller Shop · H.M.O. · Herman's Military Antiques · House of Evil · Honest John's Computers · Howard's Flowers · King Toot's · Kwik-E-Mart · Little Lisa's Recycling Plant · Lotto 'N' Liquor · Little Black Box · Maison Derriere · Make-a-Thing Workshop · Malibu Stacy Headquarters · Mall-O-Rail Station · Mapple Store · Monorail Cafe · Monroe Family Therapy Center · National Bank of Springfield · Noise Land Video Arcade · Oedipus Rx · Official Halloween HQ · Simpson Laser Tag · Sir Putt-A-Lot's · Spiffany's · Sportacus · Sprawl-Mart · Springfield Farmers Market· Springfield Grocery Store · Springfield Mall · Springfield Pet Shop · Springfield Tar Pits · Springfield Wax Museum · Testosterzone · The Gridiron · Try-N-Save · Vulgari Jewelry Store · Zenith City Times
Ah, Fudge! Factory · Ajax Steel Mill · Asia de Cuba · Beer-N-Brawl · Classy Girls Strip Club · Cracker Factory · Egg Nog Bar · El Chemistri · Florence of Arabia · Gilded Truffle · Gulp 'N' Blow · It's A Wonderful Knife · Johnny Fiestas · Krusty Burger · Krusty's Drive-Thru Station · Lard Lad Donuts · Luigi's · Madame Chao's · Moe's Tavern · Municipal House of Pancakes · Nighthawk Diner · O'Flanagan's Pub · Overpass Diner · Phineas Q. Butterfat's · Piggly's Super Smorg · Pimento Grove · Sham Rock Café · Shorty's · Singing Sirloin · Sit-N-Rotate · Skip's Diner · Springfield Slaughterhouse · Swanky Fish · The Happy Sumo · The Hungry Hun · The Java Server · Up, Up and Buffet! · Vesuvius Pizza · Zesty's Adult Education Annex · All Night Gym · Aztec Theatre · Banana Dictatorship · Barbarian Castle · Bartman Cave · Burns State Prison · Businessman's Social Club · Calmwood Mental Hospital · Center for Geriatric Medicine · Channel 6 · Claus Co · Community Center · Control Building · Cooling Towers · Court House · Death Mountain · DMV · Duff Brewery · Duff Stadium · E.A.R.L. · First Church of Lard Lad · First Church of Springfield · Fort Sensible · Fortress of Choclitude · Guinea Pig Rescue Center · Hibbert Family Practice · Itchy & Scratchy Studios · Jake's Unisex Hair Palace · KBBL Radio · Monorail Station · Monsarno Research · Museum of Natural History · Office of Unemployment · Police Station · Portal to Rigel 7 · Preparatory School · Rail Yard · Reactor Core · Republican Party HQ · Santa's Workshop · Shotgun Pete's · Springfield Buddhist Temple · Springfield Coliseum · Springfield Downs · Springfield Dump · Springfield Elementary · Springfield General Hospital · Springfield High School · Springfield Knowledgeum · Springfield Library · Springfield Post Office · Stonecutter Daycare Center · Stonecutter Lodge · Town Hall · Waverly Hills Elementary · ZiffCorp Office Building
Krustylu Studios · Lugash's Gym · Minimum Security Prison · Police Station · Springfield Observatory · Springfield Penitentiary
Blarney Castle · Cannon Control Building · Indoor Tennis Courts · Krusty's Mansion · Monsarno Cafeteria · Monsarno Chimp Resources · Monsarno Human Resources · Monsarno Library · Pet Cemetery · Seething Sisters · Shapes · Shotkickers · Springfield Cemetery · Writers Building
Botanical Garden · Glass Depot · Metal Depot · Plastic Depot · Uriah's Heap Recycling Center Giuseppe's Workshop · Helter Shelter · Ice Palace · Mausoleum · Museum of Swordfish · Old Abandoned Warehouse · Outdoor Opera Stage · Plato's Republic Casino · Powell Motors · Rancho Relaxo · Santa's Village · Springfield Clamphitheater · Springfield Country Club · Springfield Skating Rink · Stomach Staple Center · Super Collider · Toy Workshop · Woosterfield Hotel
Bart's Tree House · Cletus' Farm · Channel 6 · Drive-In Theater · KBBL Radio · Open Air Stage · Playdough Factory · Springfield Downs 50ft Magnifying Glass · Escalator To Nowhere · Fortress of Choclitude · King Homer's Skyscraper · Krusty Burger Oil Rig · Popsicle Stick Skyscraper · Sit-N-Rotate · The Sunsphere
Bloaters at the Squidport · Crypto Barn · Ferris Wheel · Just Rainsticks · Malaria Zone · Much Ado About Muffins · My First Tattoo · Planet Hype · The Frying Dutchman · The Itchy and Scratchy Store · Turban Outfitters Death Drop · Duff Pavilion · Eyeballs of Death · Gift Shop · Happy Little Elves Ride · Krustyland Burger · Krustyland Entrance · Krusty's Giant Wheel · Krustyland Hotel · Krusty's Haunted Condo · Mt. Krustmore · One Plate Maximum Buffet · Radioactive Man: The Ride · Scratchy's Flea Dipper · Sleeping Itchy's Castle · Tavern on the Scream · The Food Needle · The Tooth Chipper · Tunnel of Love · Twirl ‘n’ Hurl · Unoriginal Log Ride · Viking Boat Ride · Wet & Smokey Stunt Show Burns Slant-Drilling Co. · Red Blazer Realty · Springfield Heights Tunnel · · Shøp · Coffee Shop · L.A. Body Works · · Institute of Technology · John's Pharmaceuticals · Heights Theater · · Deluxe Condo · Business Center · Valet Parking · · Classic Mansion · Modern Mansion · · Montessori School · Ziff Mansion · · Column Mansion · Incubator Think Tank · Health Spa · Plastic Surgery Center · Polo Field House Bad Dream House · House of Evil · Mausoleum · Pet Cemetery · Springfield Cemetery · Super Collider Barney's Bowlarama · Mapple Store · Try-N-Save · Santa's Village Howard's Flowers · Phineas Q. Butterfat's · Sir Putt-A-Lot's
O'Flanagan's Pub
Duff Stadium · Fort Sensible · Lugash's Gym · Sleep-Eazy Motel · Springfield Coliseum Lincoln's Cabin · Nighthawk Diner
Ancient Burial Ground · First Church of Lard Lad · Gingerbread House · Gypsy Fortune Teller Shop · Pumpkin House · Twirl ‘n’ Hurl · Ultrahouse 2
Caesar's Pow-Wow Casino
Claus Co · Costington's · Elf Home · Egg Nog Bar · Happy Little Elves Ride · Helter Shelter · Santa's Workshop · Springfield Mall · Springfield Skating Rink Madame Chao's · Tunnel of Love · Up, Up and Buffet!
Sham Rock Café
Banana Dictatorship · Blocko Store · Crazy Cat House · Fireworks, Candy & Puppies · Johnny Fiestas
Abandoned Store · Stonecutter Daycare Center · Stonecutter Lodge
Giuseppe's Workshop
Barbarian Castle · Boxingham Palace · Castle Recycle Drive-In Theater · Make-a-Thing Workshop · Portal to Rigel 7 · Rigellian Tribal Hut · Spooky House Piggly's Super Smorg · Stomach Staple Center Cannon Control Building · Ice Palace · Sequel Stop · Toy Workshop Bartman Cave · Beach House · Botanical Garden · Burns State Prison · Crap Silo · Death Mountain · Kane Manor · National Bank of Springfield · Radioactive Man Statue · Springfield Tar Pits · Superior Squad HQ · Zenith City Apartments · Zenith City Lofts · Zenith City Store Front · Zenith City Times Gas and Grub · It's A Wonderful Knife · Italian Villa · Minimum Security Prison · Monsarno Cafeteria · Monsarno Chimp Resources · Monsarno Human Resources · Monsarno Library · Monsarno Research · Museum of Swordfish · Old Simpson Farm · Outdoor Opera Stage · Republican Party HQ · Springfield Farmers Market
Ajax Steel Mill
Alley McBalls · Testosterzone · · Springfield Arms · The Gridiron · · Sportacus · Basketball Stadium · Simpson Laser Tag
Springfield Dump · Metal Depot · Plastic Depot · Glass Depot · · Monorail Station · Tetanus Terminal · Mall-O-Rail Station · · Uriah's Heap Recycling Center · Rail Yard · · Krusty's Drive-Thru Station · Little Lisa's Recycling Plant · Monorail Cafe · Self-Reliant House
Spooky Cabin · Tenta-Corp HQ · Re-Neducation Center
The Vast Waistband
Abercrombie & Rich · Ayn Rand School for Tots · Best Snowman Ever · Buckingham Pay-Less Motel · Chocolate Shoppe · Efcot Center · Gingerbread Mansion · Exotic Petting Zoo · Fortress of Lonelitude · Moonshine Shack · Playdough Factory · Reindeer Burger Truck · Ski Chalet · Springfield Orphanage · Things Unnecessary · Virgil's Cabin · Wall E. Weasel's · Wooly Bully · X-mas Trees Slightly Irregular · · Duff Center Arena · Springfield Animal Shelter · North Pole Station · Rubber Baby Buggy Bumpers · Slide Factory · Victor's Secret
Shuttle Hangar · Space Training Center Coconut Babaloo · Der Krazy Kraut · She-She Lounge
Britannia Casino · Burns' Casino · Chinese Acrobatic Theatre · Cletus's Dice Den · Gaming Moe's · Homer's House of Cards · Impulse Wedding Chapel · La Belle Frottage · Lucky Casino · Nero's Palace Casino · Peacock Lounge · Safari Casino · Woodstock Casino
Notre Dame of Springfield
Springfield Fire Department
Bandit Fort · Bank · Blacksmith · Corral · General Store · Hootenanny Barn · Ordnance Express · Part and Parcel Postal · Sneed's Feed & Seed · Top Chop Barber Shop · Town Plaza · Wes Doobner's Rib Huts · Wild West Film Set · Wilted Rose
Pro-Shop
Alcatraaaz's Mansion · All Sales Vinyl · Classified Records · Gold Records on Walls Studio · Hip-Hop Stage · Jazzy Goodtime's · Kwik-E-Merch · New Bedlam Rest Home · Pop Stage · Quitters · Rock Stage · Rockin' Ark · Snub Club · Solomon's Temple · Sungazer Studio · The Jazz Hole ·
Cheddarbarrel Farm · Fair Pavilion · Springfield Opry House · Turn Your Head and Coif · Ye Olde Off-Ramp Inn
Magic Academy · Charmer's Market · Magic Tower · Magic Academy Library · Fantastical Beastarium · Mess Hall · Walking Kwik-E-Mart · Black Magic Hall · The Great Raymondo's Home · Elf Hotel · Magic Palace · Magic Academy Ruins · Department of Magical Vehicles
Rigellian Christmas Spaceship ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}