use strict;
my $str = 'Hello, world test(test) testing
Hello, world test(test)test testing
test()
test(a, b)
test(,)
test(,a)';
my $regex = qr/\w+\((?:\w+(?:\s*,\s*\w+)*)?\)/mp;
my $subst = '[\\d][\\d][\\d]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";