use strict;
my $str = 'Which SQL query will help you fetch the department ID and department name for departments where the number of employees exceeds 10?
| EMP_ID | F_NAME | L_NAME | SALARY | DEPT_ID_DEP |
| --- | --- | --- | --- | --- |
| 1 | John | Doe | 60000 | 101 |
| 2 | Jane | Smith | 75000 | 102 |
| 3 | Emily | Davis | 80000 | 101 |
| 4 | Michael | Johnson | 65000 | 103 |
| DEP_ID | DEP_NAME | MANAGER_ID | LOCATION_ID |
| --- | --- | --- | --- |
| 101 | IT | 10 | L0001 |
| 102 | HR | 20 | L0002 |
| 103 | Finance | 30 | L0003 |
| 104 | Marketing | 40 | L0004 |';
my $regex = qr/(^\|(\s*[A-Z][A-Z_]*\s*\|)+\s*$)\r?\n(^\|([\s-]+\|)+\s*$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}