// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^\|(\s*[A-Z][A-Z_]*\s*\|)+\s*$)\r?\n(^\|([\s-]+\|)+\s*$)").unwrap();
let string = "Which SQL query will help you fetch the department ID and department name for departments where the number of employees exceeds 10?
| EMP_ID | F_NAME | L_NAME | SALARY | DEPT_ID_DEP |
| --- | --- | --- | --- | --- |
| 1 | John | Doe | 60000 | 101 |
| 2 | Jane | Smith | 75000 | 102 |
| 3 | Emily | Davis | 80000 | 101 |
| 4 | Michael | Johnson | 65000 | 103 |
| DEP_ID | DEP_NAME | MANAGER_ID | LOCATION_ID |
| --- | --- | --- | --- |
| 101 | IT | 10 | L0001 |
| 102 | HR | 20 | L0002 |
| 103 | Finance | 30 | L0003 |
| 104 | Marketing | 40 | L0004 |";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}