package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`e[yw][A-Za-z0-9-_]+\.(?:e[yw][A-Za-z0-9-_]+)?\.[A-Za-z0-9-_]{2,}(?:(?:\.[A-Za-z0-9-_]{2,}){2})?`)
var str = `JWT pattern
- handles both JWS (3 segments) and JWE (5 segments)
- remove the ending \`(?:(?:...\` to handle JWS only
- segments 1+2 are expected tp start with \`e[yw]\`, an encoded start of JSON object \`{"\` or \`{\n\`
- remove/extend it to match used token structure
- or make it even more restrictive \`(ey[IJ]|ewo)\` to match encoded \`{"\w\` or \`{\n"\`
- payload (2nd segment) may be empty
- both header (1st segment) and payload are expected to start with \`eyJ\`, a base64 encoded start of JSON object \`{"\`
- accepts only proper Base64url encoding (RFC 4648) without Base64 padding \`=\`
- test it at https://regex101.com/r/V99DS0
eyJhbGciOiJkaXIiLCJlbmMiOiJBMjU2Q0JDLUhTNTEyIiwia2lkIjoicEw1NGdLalBHWElQVWw3eGlGN3B5MExJY3IxNkhPVlZnTXBtWjZqZmFUcUppb1h6M0FSM21EaWpTdXFxNnNvSTBoM1BaNzdMdDUzRjVUbVVPRW5KRGcifQ..LxFPkpn8Gu8vFuXDtOKA1A.DkMr_qOgv6zdyFiZGnz01wnFfLLmoMpRA-L3EbmgOGv21E-yU8ks7C_MSwA6E8KpXAB7XHeejJQWvs5ZrxDM2G8_t_BIJ6DUFXvLvLOzdo0hceeCCtujAgMPsjxW0RQFHkrA2VOlpuF7vVgJXPby19t0_QBWIaZnpfnAYzDJ98UpO1WbNxqGfdpbNG6RETpH.w1H3V7eGynuOi2qJUooceTCvoC4P5sT7bQRqbLZuyR0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}