package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(.*?)\]`)
var str = `[1379082600-1379082720],[1379082480-1379082480],[1379514420-1379515800],`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}