$re = '/^[^\]]+([^\]]+[\]]){5}[^\]]+$/m';
$str = '"[ 357\\",\\"-0.9\\",\\"99\\",\\"16 ] ] ] ] "
"[ 357\\",\\"-0.9\\",\\"99\\",\\"16 ] ] ] ] ] "
"[ 357\\",\\"-0.9\\",\\"99\\",\\"16 ] ] ] ] ] ]"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);