#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\"access_token\":\s\")[^\"]*"
Local $sString = "{"access_token": "D2L6O3vxWHlJasdlhsdflhvjODaBLD5HiJKd0y33Nt7LcVtp4S5phZ1-HvqHwn8qIB3TflApEluTvG09rO3M=", "scopes": "repository", "expires_in": 3600, "refresh_token": "ZfXk7JsdgESBZMuMHE", "token_type": "bearer"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")