re = /(?:^|:|(?<=\s))(\d{3}\-\d{3}\-\d{4})(?=[\s,;.]|$)/m
str = 'My number is 0415-555-42424854-201.
My number is 415-555-42424854-201.
My number is 0415-555-4242.
My number is 415-555-4242.
My number is 123-415-555-4242.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end