$re = '/\\\\begin\{(\w+)\}.*?\\\\end\{\1\}|\\\\(?!begin|end)\w+\{\w+\}/s';
$str = '\\questao{1}
\\begin{enumerate}
esse não
\\end{enumerate}
\\begin{enumerate}
esse sim
\\begin{enumerate}
enumerate dentro de outro, não funciona
\\end{enumerate}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
esse também não
\\end{enumerate}
\\begin{enumerate}
esse também sim
\\end{enumerate}
\\questao{3}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);