package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:[0-2]\d|[3][0-1]|\d)\.(?:[0][1-9]|[1][0-2]|\d)\.\d*|\d*-(?:[0][1-9]|[1][0-2]|\d)-(?:[0-2]\d|[3][0-1]|\d))$`)
var str = `18.03.2018
20.10.1967
03.05.2002
3.5.2002
03.5.2002
3.05.2002
18.03.18
20.10.67
03.05.02
3.5.02
03.5.02
3.05.02
2018-05-3
2018-06-03
1967-6-2
32.13.2001
15.15.2002
-1.03.3002
20.10.6a7
a20.10.67
20.10a.67`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}