using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)(?:\\{2})*""[^""\\]*(?:\\.[^""\\]*)*""(*SKIP)(*F)|\h+";
string input = @"title:""tab system"" color:=""blue"" price:>10
tit\""le:""tab system"" color:=""blue"" price:>10
tit\\\""le:""tab system"" color:=""blue"" price:>10
title:""tab system"" color:=""blue"" price:>10\""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}