import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<=[^\\.])\\.{2}[^\\.]|(?<=[^\\.])\\.{4,}[^\\.])";
final String string = "Блин. Стоп\n"
+ "Блин.. Стоп\n"
+ "Блин... Стоп\n"
+ "Блин.... Стоп\n"
+ "Блин..... Стоп";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}