#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)_balance":([1-9]\d*\.?\d*|\d\.\d*[1-9]\d*)"
Local $sString = "_balance":0 " & @CRLF & _
"_balance":7" & @CRLF & _
"_balance":75" & @CRLF & _
"_balance":0." & @CRLF & _
"_balance":0.1" & @CRLF & _
"_balance":5.25" & @CRLF & _
"_balance":0.0" & @CRLF & _
"_balance":0.001" & @CRLF & _
"_balance":0.00010"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")