package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)_balance":([1-9]\d*\.?\d*|\d\.\d*[1-9]\d*)`)
var str = `_balance":0
_balance":7
_balance":75
_balance":0.
_balance":0.1
_balance":5.25
_balance":0.0
_balance":0.001
_balance":0.00010`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}