// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)_balance":([1-9]\d*\.?\d*|\d\.\d*[1-9]\d*)"#).unwrap();
let string = "_balance\":0
_balance\":7
_balance\":75
_balance\":0.
_balance\":0.1
_balance\":5.25
_balance\":0.0
_balance\":0.001
_balance\":0.00010";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}