package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[(.+)\] (\S+) > (.+)$`)
var str = `[Player] Player1 > Hello
[Admin] Alex > Hi
[Player] Player2 > Help me, im stuck
[Mod] Jim > On my way
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}