import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[(.+)\\] (\\S+) > (.+)$";
final String string = "[Player] Player1 > Hello\n"
+ "[Admin] Alex > Hi\n"
+ "[Player] Player2 > Help me, im stuck\n"
+ "[Mod] Jim > On my way\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}