$re = '/^[0-9]{3}\-[0-9]{7}\-[0-9]{2}$/m';
$str = '123-1234567-12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);