#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m),(\w+.\w+)$"
Local $sString = "FormAttachments.ACT_RequiredImages_Load" & @CRLF & _
"" & @CRLF & _
"FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments" & @CRLF & _
"" & @CRLF & _
"FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements" & @CRLF & _
"" & @CRLF & _
"FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements,WorkOrder.SUB_CheckAttachmentsRequirements" & @CRLF & _
"" & @CRLF & _
"FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements,WorkOrder.SUB_CheckAttachmentsRequirements,WorkOrder.SUB_GetWorkOrderSUBMenuStatus" & @CRLF & _
"" & @CRLF & _
"FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements,WorkOrder.SUB_CheckAttachmentsRequirements,WorkOrder.SUB_GetWorkOrderSUBMenuStatus,WorkOrder.SUB_CheckWorkOrderStatus" & @CRLF & _
"" & @CRLF & _
"FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements,WorkOrder.SUB_CheckAttachmentsRequirements,WorkOrder.SUB_GetWorkOrderSUBMenuStatus,WorkOrder.SUB_CheckWorkOrderStatus,WorkOrder.ACT_ShowMaintHome_FromLoading" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")