// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m),(\w+.\w+)$").unwrap();
let string = "FormAttachments.ACT_RequiredImages_Load
FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments
FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements
FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements,WorkOrder.SUB_CheckAttachmentsRequirements
FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements,WorkOrder.SUB_CheckAttachmentsRequirements,WorkOrder.SUB_GetWorkOrderSUBMenuStatus
FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements,WorkOrder.SUB_CheckAttachmentsRequirements,WorkOrder.SUB_GetWorkOrderSUBMenuStatus,WorkOrder.SUB_CheckWorkOrderStatus
FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements,WorkOrder.SUB_CheckAttachmentsRequirements,WorkOrder.SUB_GetWorkOrderSUBMenuStatus,WorkOrder.SUB_CheckWorkOrderStatus,WorkOrder.ACT_ShowMaintHome_FromLoading
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}