$re = '/([[:alnum:]])\1{2,}/m';
$str = 'test111testaaatest777777testrrrrrrtest11testaatest';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);