package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^ftp\.eset\.sk|mspapi\.esetsoftware\.com$`)
var str = `ftp.eset.sk
mspapi.esetsoftware.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}