using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[1-9]\d{0,2}(?:,\d{3}){2,}|[1-9]\d{1,2},\d{3}";
string input = @"""10,400,000"",""10,900,000"",""500,000"",""1,400,000"",""1,900,000,123,564""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}