#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<SomeXmlProperty[^<]*\/>"
Local $sString = "<SomeXmlProperty att="abc" " & @CRLF & _
"att2="def"" & @CRLF & _
"att3="ghi"/>" & @CRLF & _
"<SomeXmlProperty att4="jkl" " & @CRLF & _
"att5="mno"" & @CRLF & _
"att6="pqr"><SomeXmlProperty>" & @CRLF & _
"<SomeXmlProperty att="stu" " & @CRLF & _
"att3="vwx"" & @CRLF & _
"att6="yz" " & @CRLF & _
"/>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")