import Foundation
let pattern = #"<SomeXmlProperty[^<]*\/>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<SomeXmlProperty att="abc"
att2="def"
att3="ghi"/>
<SomeXmlProperty att4="jkl"
att5="mno"
att6="pqr"><SomeXmlProperty>
<SomeXmlProperty att="stu"
att3="vwx"
att6="yz"
/>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)