re = /\*\*(?:.+\*\*)*(.+)/m
str = 'abc ** this does not match ** but I guess this * bit does'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end