#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\+?998?\s?-?(90|91|93|94|95|98|99|33|97|71)\s?-?(\d{3})\s?-?(\d{2})\s?-?(\d{2})$"
Local $sString = "998903641905"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")