$re = '/(?i)[a-z]{3,10}://[^/\s:@]{3,20}(?<!user):(?!example)(?!pass])[^/\s:@]{3,20}(?<!password)(?<!example)@(?!example)(?!127\.0\.0\.1)(?!localhost).{8,100}/m';
$str = 'mysql://admin:admin@something.com:3306/db_name\\n';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);