package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[:blank:]`)
var str = `aaaaaa
bbbbbb
cccccc
h
hi
hii
hiii
hiiii
hiiiii
abcdefghijklmnopqrstuvwxyz
\s
{}[]()^$+*?.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}