#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)@php\((.*?)\)(?= @php|$|\\r|\\n)"
Local $sString = "@php($hiddenUrl = !empty($hiddenUrl) ?? false)\r\n" & @CRLF & _
"<span class="info__item">\r\n" & @CRLF & _
" @if($hiddenUrl)\r\n" & @CRLF & _
" <div class="info__icon" style="background-image: url('{{ $image }}');" title="{{ $name }}"></div>\r\n" & @CRLF & _
" @else\r\n" & @CRLF & _
" <a class="info__icon" style="background-image: url('{{ $image }}');" href="{{ $url }}" title="{{ $name }}"></a>\r\n" & @CRLF & _
" @endif\r\n" & @CRLF & _
"</span>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")