const regex = /@php\((.*?)\)(?= @php|$|\\r|\\n)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@php\\((.*?)\\)(?= @php|$|\\\\r|\\\\n)', 'mg')
const str = `@php(\$hiddenUrl = !empty(\$hiddenUrl) ?? false)\\r\\n
<span class="info__item">\\r\\n
@if(\$hiddenUrl)\\r\\n
<div class="info__icon" style="background-image: url('{{ \$image }}');" title="{{ \$name }}"></div>\\r\\n
@else\\r\\n
<a class="info__icon" style="background-image: url('{{ \$image }}');" href="{{ \$url }}" title="{{ \$name }}"></a>\\r\\n
@endif\\r\\n
</span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}