import Foundation
let pattern = #"@php\((.*?)\)(?= @php|$|\\r|\\n)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
@php($hiddenUrl = !empty($hiddenUrl) ?? false)\r\n
<span class="info__item">\r\n
@if($hiddenUrl)\r\n
<div class="info__icon" style="background-image: url('{{ $image }}');" title="{{ $name }}"></div>\r\n
@else\r\n
<a class="info__icon" style="background-image: url('{{ $image }}');" href="{{ $url }}" title="{{ $name }}"></a>\r\n
@endif\r\n
</span>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)